Imperva Cyber Community

Expand all | Collapse all

Agent will not stay Running

  • 1.  Agent will not stay Running

    Posted 21 days ago
    Has anyone had issues on Linux server running Oracle with the agent not staying "Running".  I have an issue across several servers that after restarting the agent it will not stay running.  Even stranger, as long as I stay in the CLI menu after starting it, it will run.  As soon as I quit the session the agent stops.  Previously opened a case and only solution was a server reboot.  Running 13.6 on appliances with agent version 14.1.  Thanks.
    #ImpervaAgent

    ------------------------------
    Eric Schmitt
    IT Systems Analyst
    San Antonio TX
    ------------------------------


  • 2.  RE: Agent will not stay Running

    CHAMPION
    Posted 19 days ago
    Was the agent installed using the root user?  It sounds like the agent is terminating when you close your session.

    What version of Linux are you running? 
    If it is Oracle Linux with the unbreakable kernel (OEL-UEK) or SuSE, then there are special install instructions.

    I've had some issues with newer versions of OEL-UEK because there are packages that the OS build team chose not to install that were needed by the Imperva installer..

    ------------------------------
    Robert Miller
    Senior Cybersecurity Engineer
    Bank of the West
    Lavista NE
    ------------------------------



  • 3.  RE: Agent will not stay Running

    Posted 19 days ago
    The agent is installed as the root user and it seems all of the systems I have seen this on are RHEL 7.

    It does sound like the agent is terminating when I close my session which I do not really understand.  It will do this until the server is rebooted and then all is well.  I am just hoping someone may have seen this so we can determine a fix without having to reboot.  A different team manages the server and is not always receptive to reboots.

    ------------------------------
    Eric Schmitt
    IT Systems Analyst
    San Antonio TX
    ------------------------------



  • 4.  RE: Agent will not stay Running

    CHAMPION
    Posted 19 days ago
    Will the agent restart from command line using /opt/imperva/ragent/bin/rainit start 
    or does it always require a reboot.

    Have you ran the which_agent script to make sure you're on the current agent version for the OS?
    I have seen odd problems when the server gets upgraded without upgrading the agent.

    Can you check the logs for the agent, look at /opt/imperva/ragent/etc/logs/ragent/ragent_log.htm
    It may show you what is happening to the agent.

    ------------------------------
    Robert Miller
    Senior Cybersecurity Engineer
    Bank of the West
    Lavista NE
    ------------------------------