Imperva Cyber Community

Expand all | Collapse all

securesphere was unable to perform the operation. please refresh your screen. if the problem persists, contact Imperva Technical Support

Jump to Best Answer
  • 1.  securesphere was unable to perform the operation. please refresh your screen. if the problem persists, contact Imperva Technical Support

    Posted 12-14-2020 12:24
      |   view attached
    Hi,

    I am getting an error when I am going to change/update Default Server GRoup for Linux Agent. 

    1. Agent Status is running. 
    2. Restarted Agent and tried but no luck.
    3. Server group is available in site tree.

    Error :  securesphere was unable to perform the operation. please refresh your screen. if the problem persists, contact Imperva Technical Support

    Is anyone face similar issue?

    Thanks
    Vishal
    #ImpervaAgent

    ------------------------------
    Vishal Navale
    concord NC
    ------------------------------


  • 2.  RE: securesphere was unable to perform the operation. please refresh your screen. if the problem persists, contact Imperva Technical Support

    CHAMPION
    Posted 12-17-2020 16:45

    I have had this happen when some field is not set or is set incorrectly. Either on the settings tab or the data interfaces tab.

    When you do the pulldown for the Default Server Group, is your server under the Related Server Groups by Protected IPs section?

    If you attempt to change it, do you get the warning popup about removing assigned services?  And if you click OK, then you get a message about assigning services on the data interface tab.

    I was able to change an agent to not have a server group, and then back to the correct server group without issue.



    ------------------------------
    Robert Miller
    Bank of the West
    Omaha NE
    ------------------------------



  • 3.  RE: securesphere was unable to perform the operation. please refresh your screen. if the problem persists, contact Imperva Technical Support
    Best Answer

    CHAMPION
    Posted 12-17-2020 17:08

    If the server group shows as Non related server groups by protected IPs, then you need to add the server to the group in the site tree.

    Go to sites, select the server group, then on the servers tab add your server and make it protected.   Then you should be able to select it on your agent settings.

    If that does not work, you probably need to open a case.



    ------------------------------
    Robert Miller
    Bank of the West
    Omaha NE
    ------------------------------



  • 4.  RE: securesphere was unable to perform the operation. please refresh your screen. if the problem persists, contact Imperva Technical Support

    Posted 12-18-2020 08:20

    Hi Robert,

    Even i am getting an same error when i was tried to add in protected ip.

    Thanks

    Vishal



    ------------------------------
    Vishal Navale
    concord NC
    ------------------------------