Imperva Cyber Community

Expand all | Collapse all

Error install.sh

  • 1.  Error install.sh

    Posted 12-03-2020 12:33
    Hi all,

    I tried install an Imperva DAM agent on Suse11 but the install process didn't work. We checked the modprobe, buy we didn't know how Imperva works with it or which properties we needs modify.

    Could you help us?

    I attach the install log to check it:

    Checking if the Remote Agent should be installed or upgraded:

    SELF EXTRACTING INSTALLER

    PACKAGE CONFIGURATION
    Version: 3.5.0.20.0
    Release: 567601
    OS: Linux
    OS Version: 3.0
    Platform: x86_64
    Kernel Patch Level: 196709
    Maximum # of permitted CPUs: 4096
    Root Dir:
    Required Disk Space: 55021K
    Ignored Tests:

    SYSTEM CONFIGURATION
    OS: Linux
    OS Version: 3.0.101-108.87-default
    Platform: x86_64
    Kernel Patch Level:
    Maximum # of permitted CPUs: 4096
    User ID: uid=0(root) gid=0(root) groups=0(root)
    Available Disk Space: 0K
    Zone: global

    VERIFYING CONFIGURATION
    Test 1: Root Permissions. Passed
    Test 2: OS Compatibility. Passed
    Test 3: Platform Compatibility. Passed
    Test 4: Necessary OS Commands. Failed: The command modprobe could not be found on the system.
    Operation aborted. For more information, see the Prerequisite Tests for non-Windows Agents in the Installing Agents chapter in the SecureSphere Administration Guide.

    Failed to get information regarding currently installed Remote Agent.

    Regards.


    #DatabaseActivityMonitoring

    ------------------------------
    matías di cola
    ------------------------------


  • 2.  RE: Error install.sh

    Posted 12-03-2020 12:47
    Additional info:

    We use this agent: Imperva-ragent-SLE-v11SP4-kSMP-px86_64-b13.5.0.21.0.572362.tar.gz

    Imperva-ragent-SLE-v11SP4-kSMP-px86_64-b13.5.0.21.0.572362.bsx
    agent.metadata
    install.sh
    README
    Imperva-ragentinstaller-SLE-v11SP4-kSMP-px86_64-b3.5.0.20.0.567601.bsx
    public_key_SLE-v11SP4-kSMP-px86_64.der

    ------------------------------
    matías di cola
    ------------------------------



  • 3.  RE: Error install.sh

    CHAMPION
    Posted 12-03-2020 16:40
    Did you run the which_ragent_package script to determine the correct agent version to install?

    The version of the script I have shows a 13.6 agent for SLES v11SP4.

    The agent needs to be installed with a user with root privileges.  That may have produced the modprobe error, as modprobe should be installed in the OS.
    If this is the first time install on this SLES server, then you have to use the -k kabi_*.txt  parameter with the correct kabi file name.

    ------------------------------
    Robert Miller
    Bank of the West
    Omaha NE
    ------------------------------



  • 4.  RE: Error install.sh

    Posted 12-11-2020 12:50
    Hi Robert,

    Thanks for you answer.
    We ran the which_ragent_package script and the ragent installed was OK. The agents was intalled with root privileges but the modprobe error continues. The modprobe is installed in the OS.
    we tried install with kabi file but nothing change.

    Did you know anything else to do? 


    ------------------------------
    matías di cola
    ------------------------------



  • 5.  RE: Error install.sh

    Imperva Employee
    Posted 12-14-2020 08:56
    For details on the prerequisites, check out https://docs.imperva.com/bundle/v14.1-security-for-sharepoint-user-guide/page/3050.htm (I know it says for SharePoint, but I think the prereq checks are the same).  

    If that doesn't work, open a ticket with support if you haven't already.  They can work with you to resolve any issues in your specific environment.

    Jim

    ------------------------------
    Jim Burtoft
    Imperva
    PA
    ------------------------------