Imperva Cyber Community

 View Only
Expand all | Collapse all

Registration Failed: Failed to send/receive data to url / ragent_register

  • 1.  Registration Failed: Failed to send/receive data to url / ragent_register

    Posted 03-28-2022 12:50
    I am trying to install Imperva Secure Sphere Agent but it gives me the error " Registration Failed: Failed to send/receive data to url / ragent_register "

    SQL server Details:
    --------------------------
    IP: 192.168.2.111/24
    OS: Windows Server 2016
    SQL Version: SQL Server 2014 Developer Edition


    Gateway Details:
    -----------------------
    Installed Version: 14.7.1.20_0
    Management IP: 192.168.1.51/24
    LAN IP: 192.168.2.51/24


    MX Details: 
    ---------------
    Installed Version: 14.7.1.20
    Management IP: 192.168.1.50/24



    #DatabaseActivityMonitoring

    ------------------------------
    Olgerta Prendi
    Cyber Security Specialist
    Tirana
    ------------------------------


  • 2.  RE: Registration Failed: Failed to send/receive data to url / ragent_register

    Posted 03-29-2022 05:40
    Hi Olgerta,

    Thanks for the post. 

    I came across a link that may help here:
    "Failed to send/receive registration data"

    Summary 

    This article describes what actions to take if Agent registration failed.

    Steps 

    If the agent registration fails with the error "Failed to send/receive registration data", it could be because of one of the following: 

    1. No listener defined on the gateway. Please refer to chapter "remote agents" in database user guide for detailed instructions to define the listener.
    2. No connectivity between agent and gateway on port 443. To check the connectivity from database server to gateway, run the command below. 
      - telnet 443 Control TCP port should succeed from the agent server

    If the listener is defined and the connectivity test succeeds and if registration still fails, please let me know.

    Thanks,



    ------------------------------
    Sarah Lamont(csp)
    Digital Community Manager
    ------------------------------



  • 3.  RE: Registration Failed: Failed to send/receive data to url / ragent_register

    Posted 03-29-2022 07:26
    Hi,

    I suppose that the problem may be in routing.
    You have two network interfaces in two different VLANs.

    1. You should check where the default gateway is defined, on which interface MGMT or LAN?
    2. On which interface you have created the agent interface? Is the same interface with the default gateway? If not, then you have to add a route in the agent route option on IMPERVA's Gateway.




    ------------------------------
    Karol Gruszczyński
    IT Security Expert
    Trafford IT
    Warsaw
    ------------------------------



  • 4.  RE: Registration Failed: Failed to send/receive data to url / ragent_register

    Posted 03-29-2022 10:46
    Both, the MX and DAM has two interfaces , where one interface is connected to the management network (192.168.1.0/24) and the other interface is connected to the LAN Network (192.168.2.0/24) where my clients are located.

    MX Details:
    --------------------
    MGMT Interface: 192.168.1.50
    LAN Interface: 192.168.2.50

    DAM Details:
    ----------------------
    MGMT Interface: 192.168.1.51
    LAN Interface: 192.168.2.51

    SQL Server Details:
    ---------------------
    IP: 192.168.2.111

    On the DAM I have created a listener on the LAN Interface on port 5555 with SSL.

    On the Database Server while trying to install the agent I specify the LAN IP of the DAM.

    The DAM and the MX can communicate with each others using the Management Network and on the MX Secure Sphere Interface I can see the DAM listed and the communication is working fine.

    Attached you will also find the diagram of my Lab Setup. I hope this will help you to create an idea of what I wanted to achieve and help me with the error.

    Registration Failed: Failed to send/receive data to url / ragent_register


    ------------------------------
    Olgerta Prendi
    Cyber Security Specialist
    Tirana
    ------------------------------



  • 5.  RE: Registration Failed: Failed to send/receive data to url / ragent_register

    Posted 03-29-2022 17:55
    Did you check the connection between the agent interface and SQL server using the telnet command??
    Maybe a local firewall blocks 5555 ports?

    If you need help write me on priv and we try to arrange the zoom meeting. I'll try to help you.



    ------------------------------
    Karol Gruszczyński
    IT Security Expert
    Trafford IT
    Warsaw
    ------------------------------



  • 6.  RE: Registration Failed: Failed to send/receive data to url / ragent_register

    Posted 04-20-2022 11:17
    Hi Karol,

    I have written you on private and waiting for your response.

    ------------------------------
    Olgerta Prendi
    Cyber Security Specialist
    Tirana
    ------------------------------



  • 7.  RE: Registration Failed: Failed to send/receive data to url / ragent_register

    Posted 04-22-2022 09:52

    Hello Olegrate

    I have the same issue.

    If you issue is solved could you please help me. Is it necessary to open port 5555 between DB and Gateway listener interface for registration of agent ?



    ------------------------------
    Ashutosh Chaurasia
    Senior Security Engineer
    Melbourne VIC
    ------------------------------



  • 8.  RE: Registration Failed: Failed to send/receive data to url / ragent_register

    Posted 04-26-2022 11:23
    Hi All,

    I checked in with @Karol Gruszczyński briefly and he suggested the following...

    "I think that the problem was because the default option in the network interface is set as sniffing.

    So, when creating the listener interface for agents, you have to turn off the sniffing settings for this interface.

    The agent listener interface cannot be configured on the sniffing interface."


    ​Let me know if this helps?


    ------------------------------
    Sarah Lamont(csp)
    Digital Community Manager
    ------------------------------



  • 9.  RE: Registration Failed: Failed to send/receive data to url / ragent_register

    Posted 04-29-2022 03:42
    Hi Team & Ashutosh,

    I find the solution for the issue.

    In the beginning the gateway mode was on Bridge STP. I change it and add the gateway mode on sniffing.
    Secondly, as for the agent listener interface must add with the GW IP and in the port 5555. The last step is to install the agent & then it works.

    Thank you for your disponibility.

    Hope this case will help also other community members & you Ashutosh Chaurasia

    Kind Regards,
    Gerta

    ------------------------------
    Olgerta Prendi
    Cyber Security Specialist
    Tirana
    ------------------------------



  • 10.  RE: Registration Failed: Failed to send/receive data to url / ragent_register

    Posted 04-29-2022 07:01

    Thanks so much for the update @Olgerta Prendi​. It's so helpful for other users that face the same scenario.

    Ashutosh - let us know if you also manage to solve it. 

    Thanks,

    Sarah



    ------------------------------
    Sarah Lamont(csp)
    Digital Community Manager
    ------------------------------



  • 11.  RE: Registration Failed: Failed to send/receive data to url / ragent_register

    Posted 05-06-2022 03:33

    Hello @Sarah Lamont(csp) @Olgerta Prendi

    I am still having the same issue, I am able to telnet on port 443 from database to the listener ip defined.

    Telnet from DB on listener interface on port 5555 is getting failed. IT could be the reason ?

    PFB my gateway configuration:-​​




    Thanks for your support!!

    Br//
    Ashutosh



    ------------------------------
    Ashutosh Chaurasia
    Senior Security Engineer
    Melbourne VIC
    ------------------------------



  • 12.  RE: Registration Failed: Failed to send/receive data to url / ragent_register

    Posted 05-06-2022 04:23
    Hello Ashutosh.

    Did you try on device = eth0 , ssl = true on port: 5555 with the GW_mgmt_interface_IP_address/24?

    Let me know if it works.

    BR, 
    Gerta

    ------------------------------
    Olgerta Prendi
    Cyber Security Specialist
    S&T Albania
    Tirana
    ------------------------------



  • 13.  RE: Registration Failed: Failed to send/receive data to url / ragent_register

    Posted 4 days ago

    Hello @Olgerta Prendi

    Thanks for all your reply.

    Issue got solved.

    Br//
    Ashutosh​



    ------------------------------
    Ashutosh Chaurasia
    Senior Security Engineer
    Melbourne VIC
    ------------------------------