Imperva Cyber Community

communities_1.jpg
 View Only
  • 1.  It failed when started the agent integration from the DB server to the gateway interface (eth1).

    Posted 24 days ago

    Using a dual network cluster topology, we created a gateway cluster (3+1).

    Defined two interfaces for each gateway.

    Interface (eth0) MGMNT and Cluster communication and Interface (eth1) Agent Listener interface between agents and gateways.

    It failed when we started the agent integration from the DB server to the gateway interface (eth1).

    We also checked the firewall side, and they received the allowed logs from the DB server to the Gateway end.
    As well as we added Ragent Route in the gateway.


    Please someone help me to solve this problem as DB is not able to communicate to GW LAN1.


    #DatabaseActivityMonitoring
    #ImpervaAgent

    ------------------------------
    MOHAMMED YASIN
    Professional Services Consultant
    StarLink DMCC
    dubai WA
    ------------------------------


  • 2.  RE: It failed when started the agent integration from the DB server to the gateway interface (eth1).

    Posted 24 days ago

    Hi Mohammed,

    It could be many reasons for such failure. I would suggest you to open case to On-Prem Support and share this description, as well as the output of the agent registration  attempt, including the error you get at the end. Probably additional info will be required ( like GTIs from all involved components), support engineer will let you know what info is exactly required to address this issue.



    ------------------------------
    Marat Makhlin
    Imperva
    On-Prem Technical Lead
    ------------------------------



  • 3.  RE: It failed when started the agent integration from the DB server to the gateway interface (eth1).

    Posted 24 days ago

    Support won't support here as this is a new deployment.

    during the registration of the agent, I countered this error Failed to send/receive data to url / ragent_register

    so I tried to telnet the port 443 and 5555 timeout.

    even if I can't ping the LAN1 I can be able to ping eth0 MGMNT IPs.

    network team replied that there is no default gateway IP of LAN1 so it's not reaching.



    ------------------------------
    MOHAMMED YASIN
    Professional Services Consultant
    StarLink DMCC
    dubai WA
    ------------------------------



  • 4.  RE: It failed when started the agent integration from the DB server to the gateway interface (eth1).

    Posted 24 days ago

    Support assists On-Prem customers  in all problems related to Imperva On-Prem products.

    As for the error itself -  it is generic error and still requires proper investigation to come to the root cause and relevant solutions. Otherwise it would be guess&try approach.

     From networking point of view it is important to ensure connectivity between agent ( DB server IP) and agent listener IP on the GW for ports 443 and configured data port ( 5555 by default).



    ------------------------------
    Marat Makhlin
    Imperva
    On-Prem Technical Lead
    ------------------------------