Imperva Cyber Community

 View Only
  • 1.  Configure NTP servers manually into MX and GW

    Posted 12 days ago
    Hello 

    looking the command to manually add NTP servers to my MX and GW. Why i trying to do this with CLI? Well the Time servers configuration (NTP) option doesn't appear in the options menu. Instead appears a message "NTP DHCP globaly" or something related.

    found this command 

    impctl platform time config --server=<NTP-server>

    I tried differente combinations

    impctl platform time config --server=<192.168.100.20>
    impctl platform time config --server=<192.168.100.20/24>

    But didn't work. let me know any solution

    Thank you


    #AllImperva

    ------------------------------
    Gehovani Flores
    Ingeniero
    Antiguo Cuscatlan
    ------------------------------


  • 2.  RE: Configure NTP servers manually into MX and GW

    Posted 12 days ago
    Hello Gehovani,

    I don't know if you read the article below and could help you:

    https://docs.imperva.com/bundle/v14.7-dam-administration-guide/page/7295.htm


    Regards,
    Gerta

    ------------------------------
    Olgerta Prendi
    Cyber Security Specialist
    S&T Albania
    Tirana
    ------------------------------



  • 3.  RE: Configure NTP servers manually into MX and GW

    Posted 11 days ago

    As you can see the NTP options doesnt appear in my MX or GW. So I read the NTP part of the manual but nothing related appears.

    Best regards


    ------------------------------
    Gehovani Flores
    Ingeniero
    Antiguo Cuscatlan
    ------------------------------



  • 4.  RE: Configure NTP servers manually into MX and GW

    Posted 11 days ago
    Hi Gehovani!

    I had the same issue, but I could not remove the "dhcp" flag from the configuration with the standard command. Even the deletion of all time settings with "impctl platform time delete -all" didn't lead to a successful end. So, I did the hard way: Attention it is not recommended to edit the bootstrap.xml. You should verify this with the support, if you want to.

    1. impctl platform time delete --all
    2. open the "/opt/SecureSphere/etc/bootstrap.xml" and search for "platform" (vi/m should give you the power) and change:

    from:

    <platform>
    ....
    <time>
    <dhcp>true</dhcp>
    <servers>
    </server>
    </servers>
    <time-zone>Europe/Berlin</time-zone>
    </time>
    ....
    to:

    <platform>
    ....
    <time>
    <dhcp>false</dhcp>
    <servers>
    </server>
    </servers>
    <time-zone>Europe/Berlin</time-zone>
    </time>

    3. Exit the editor.

    After that you will see that the display of "configured using dhcp" will disappear.

    Use "impcfg" again to set your server(s). Apply the settings and wait for service restart.

    best regards

    Stefan

    ------------------------------
    Stefan Behrends
    Senior Specialist IT-Security / Data Analytics & Forensics
    Mitte
    ------------------------------



  • 5.  RE: Configure NTP servers manually into MX and GW

    Posted 10 days ago
    Hi Gehovani,

    Can you try the following steps and let us know the results? It may help:

    • SSH to the machine.
    • Enter the following commands:


      impctl teardown

      impctl platform time delete --all

      impctl platform time config --server=192.168.100.20

      impctl boot



    ------------------------------
    Cezmi Cal
    technical support engineer
    Barikat Cyber Security
    Ankara
    ------------------------------